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Creatng Accessible iTunes U Content

Introducton
With iTunes U, students, educators, and the public have anytme, anywhere access to a 
contnually growing and comprehensive collecton of free educatonal media that 
includes movies, audio fles, and PDFs. By taking the steps to make these media fles fully 
accessible, iTunes U content providers will ensure that all students and others can fully 
beneft from these valuable educatonal resources.

This guide will teach you how to make your iTunes U materials accessible for those 
people who are deaf, hard of hearing, blind or visually impaired. Afer a brief review of 
accessibility and access technology, you will learn how to add captons, foreign-language 
subttles and audio descriptons to multmedia playable in iTunes and QuickTime Player, 
as well as mobile devices such as iPhone and iPod. You’ll also learn how to create 
accessible PDF documents to support the multmedia on your iTunes U site.

Part 1:  Understanding Accessibility and iTunes Multmedia

1.1: Overview of Terms and Concepts

Before learning how to create accessible iTunes materials, it will be helpful to defne 
terms and concepts relevant to accessible multmedia in iTunes.

Captons

Captons were originally invented nearly 40 years ago to help deaf and hard-of-hearing 
people understand television, but they are in fact useful to everyone. Captons are 
always writen in the same language as the audio. They not only render the main audio 
track (known as program audio) as text on the screen, they also indicate important non-
speech informaton, such as sound efects, music and laughter. In some countries they 
are called subttles, which is not the same as foreign-language subttles (see below). 

Captons are either closed or open. Closed captons are transmited as data along with 
the video but are not visible untl the user elects to turn them on, usually by invoking an 
on-screen control or menu selecton. Open captons are always visible; they have been 
merged with the video track and cannot be turned of. The rules and regulatons related 
to closed captons can be found on the Federal Communicatons Commission’s website.

SCC captons

The SCC (Scenarist Closed Capton) fle format is a human-readable representaton of the 
actual line-21 closed-capton data carried in the NTSC broadcast signal.  Data in the SCC 
format are closed captons that can be embedded into iTunes-compatble video or audio 
fles, and can be decoded by QuickTime Player (7.1.6 or greater), iTunes (7.4 or greater), 
iPhone, iPod touch and iPod nano. These devices ofer a menu choice or an on-screen 
switch to toggle the capton text on and of.  SCC captons cannot be styled by the 
author; that is, their display characteristcs (font face and size, background color, 
background opacity, etc.) are determined by a combinaton of the capton data and the 
playback device.

file:///Users/geoff_freed/Desktop/NCAM/SP/Apple/iTunes_U/FINAL iTUNES U GUIDELINES/Federal Communications Commision's website
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Below is an image of SCC captons being played in iTunes. You can also watch a brief 
video clip with SCC captons.

QTText captons

QTText is a text format from Apple used primarily for creatng and displaying captons 
and foreign-language subttles. They can be open or closed (see Part 1.5 for important 
informaton), and nearly all display characteristcs of QTText captons can be specifed by 
the author: font face, size, weight, color, etc. The capton region (the box in which the 
captons are displayed) can have a solid background, a translucent background or a 
transparent background, and can be placed directly over the video region or adjacent to 
the edges of the video region. In most cases, QTText captons integrated into iTunes 
multmedia will be open. Below is an image showing one example of QTText captons. 
You can also view a brief video clip with QTText captons.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2086080798?i=2050997569
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083381266?i=1884927864
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083381266?i=1884927864
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Foreign-language subttles

Foreign-language subttles are a translaton of dialog or narraton into words on the 
screen. Unlike captons, subttles are not strictly intended for use by deaf or hard-of-
hearing viewers and so do not contain non-speech elements. In iTunes multmedia, 
subttles can be created using QTText. QuickTime Player, iTunes and iPhone also have a 
built-in menu to toggle between multple subttle tracks when the text has been 
encoded in a special manner; see Part 3.2 for details.

Audio descriptons

Audio descriptons (also known as video descriptons or simply descriptons) make visual 
media accessible to people who are blind or visually impaired by providing descriptve 
narraton of key visual elements. These elements include actons, costumes, gestures, 
scene changes or any other important visual informaton that someone who cannot see 
the screen might ordinarily miss. Descriptons are usually tmed and recorded to ft into 
natural pauses in the program-audio track. Watch a brief video clip with audio 
descriptons.

As with captons, descriptons can be open or closed. Open descriptons are merged 
with the program-audio track and cannot be turned of by the viewer. In most cases, 
descriptons integrated into iTunes multmedia will be open. Closed descriptons can be 
recorded as a separate track containing descriptons only, tmed to play at specifc spots 
in the tmeline and played in parallel with the program-audio track. Authors may also 
include two program-audio tracks within a single movie—one with descriptons and one 
without. See Part 1.5 for important informaton about accessing closed descriptons in 
iTunes U multmedia. 

Screen reader

A screen reader locates informaton seen on the computer screen and vocalizes it using 
speech synthesis sofware. A screen reader applicaton is purchased separately and 
added to a computer to enable it to be used by people who are blind and visually 
impaired. Mac OS X comes with a built-in screen reader, VoiceOver; Windows screen 
readers are third-party devices that must be purchased and installed by the user. Screen 
readers are available for desktop and laptop computers as well as certain mobile 
devices, including iPhone 3GS. Similarly, both iPod nano and iPod shufe make use of 
speech synthesis technology (via spoken menus and VoiceOver, respectvely) to navigate 
menus and playlists without sight. 

1.2: Benefts of captons and audio descriptons

Both captons and audio descriptons are useful to a wide array of users in additon to 
their originally intended audiences. Groups who beneft include, but are not limited to, 
the following:

• Anyone in a noisy environment, or an environment where loud volume is not 
appropriate. Gyms, bars and restaurants regularly employ captons as a way for 
patrons to watch television while in those establishments.

• People learning to read or learning English as a second language. Research has shown 
that captons help reinforce vocabulary and language.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084757097?i=1688519967
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084757097?i=1688519967
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• Students grappling with difcult materials or concepts. Audio descriptons can be used 
to give supplemental informaton about what is on screen—the structure of lengthy 
mathematcal equatons or the intricacies of a paintng, for example.

• The aging populaton. As a large porton of the populaton grows older, both captons 
and audio descriptons could become important for people who develop sensory 
disabilites that accompany the aging process.

• Researchers. Captons can provide a powerful search capability, allowing users to 
search the capton text to locate a specifc video or an exact point in a video.

1.3: Accessible PDF documentaton

iTunes U allows you to upload not just audio and video materials; it also supports PDF 
documentaton. PDF is a popular format from Adobe that preserves the fonts, images, 
graphics and layout of nearly any source document. This ensures that users will see the 
fnished document exactly as the author intended. 

PDFs can be created so that people with disabilites can access them. In order for PDFs 
to be accessible, they need to be created using properly structured tags, appropriate 
alternatve informaton where necessary (e.g., image tags must contain alt text), and the 
tags must refect the proper reading order. If a document is created with this in mind, it 
can be successfully accessed using a screen reader or other assistve technology.

Screen-reader users are especially afected by the way in which the PDF is created, so it 
is crucial that PDFs be authored to be accessible by everyone. A PDF that hasn’t been 
made accessible can be difcult or even impossible for a blind or visually impaired user 
to navigate. A variety of tools and techniques exist to create accessible PDFs, but authors 
must be careful to observe the approaches outlined in Part 5 to ensure that the 
document is usable by everyone.

1.4: Tools for creatng accessible iTunes materials

If you’re new to iTunes U, start by visitng the iTunes U site for general informaton and 
links to discussion forums and support materials. “Creatng Your iTunes U Site” from 
Apple Educaton will give you basic informaton about how to build your frst iTunes U 
site. If you aren’t sure what video and audio formats are compatble with iTunes U, or 
have never created video or audio clips before, read “Creatng Content for iPod + iTunes” 
from Apple Educaton before proceeding any further. 

Below is a basic list of applicatons and support materials you’ll need to make your 
iTunes U materials accessible.

Multmedia:

• Captoning sofware (see Part 2, Table 1)

• QuickTime Player Pro 7.X  

• A text editor (such as TextEdit or NotePad)

• Audio-recording sofware, such as QuickTime,   GarageBand  ,   Audacity  ,   Logic   or   Sound   
Forge

http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/logicstudio/logicpro/
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://audacity.sourceforge.net/
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/ilife/garageband/
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/quicktime/
http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
http://images.apple.com/support/itunes_u/docs/iTunes_Create_U_Guide.pdf
http://www.apple.com/education/mobile-learning/
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PDF:

• Adobe Acrobat 9 Pro  

• A screen reader such as Jaws, Window-Eyes or VoiceOver

Other sofware may be necessary for certain procedures (for example, adding closed 
subttles for playback on iPhone or adding wired sprites for toggling captons or 
descriptons on and of from within QuickTime and iTunes). These applicatons are 
discussed in the documentaton.

Note: Using wired sprites. Wired sprites are QuickTime tracks that add interactvity to a 
presentaton. For accessibility purposes, wired sprites can be used for turning audio 
descriptons or QTText captons on and of. The process of integratng them into a 
multmedia presentaton is described in Appendix 1. If you’ve never seen them before, 
watch a sample video containing wired sprites.

The use of wired sprites is included in this document for the sake of completeness, but 
they may not be appropriate for all situatons. It is important to note that wired sprites 
can be operated only in QuickTime Player or iTunes. They cannot currently be used on 
iPhone or iPod. If you choose to put movies containing wired sprites in iTunes U, 
therefore, you should make it clear to the user that the sprites can only be operated on 
specifc players.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084821080?i=1842088322
http://www.adobe.com/products/acrobat/
http://www.adobe.com/products/acrobat/
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Part 2:  Creatng Captons for iTunes Multmedia
Writng captons is not necessarily a difcult task, but it does require some forethought 
and planning. This secton will provide you with informaton on choosing and 
implementng a capton format, budgetng tme and when to consider having an outside 
vendor create the capton fles for you. 

Captons should be added to a presentaton once the video and audio elements have 
been completed. Waitng to author captons untl the end of the producton process will 
ensure that they accurately refect the program audio. If you must re-edit the video or 
audio afer the captons have been created, you may have to re-edit the captons as well. 

iTunes U multmedia supports two capton formats: SCC and QTText. Both are explained 
in detail below; see Part 1.1 for a general discussion about the diferences between the 
two. Broadly speaking, the SCC format is best for implementng closed captons, and 
QTText is best for open captons and foreign-language subttles. QTText can also be used 
to display closed captons, but you must create a wired sprite to turn the captons on 
and of. See Part 1.5 for more informaton about wired sprites. 

In many ways, closed captons ofer the best experience for all viewers because they are 
hidden unless explicitly revealed by the user. Open captons are suitable in situatons 
where the author needs control over specifc characteristcs of the text (color or font 
face, for example), or when the most efectve opton is to simply always have the 
captons visible. Provided the text accurately refects the audio and is clearly displayed, 
however, both closed and open captons work equally well to make multmedia 
accessible to deaf and hard-of-hearing viewers.

When developing a workfow for a project, remember to include enough tme to write 
captons and integrate them into the fnal presentaton. How much tme is required will, 
of course, vary with each project. For example, a 10-minute documentary-style clip will 
probably take less tme to capton than a clip of the same length but with multple 
speakers and frequent shot changes. How much experience the author has in writng 
captons will also afect the tmeline: someone new to the process may take several 
hours more to create the data than someone familiar with the process. To save 
producton tme, select and learn to use captoning sofware before you actually need to 
capton your multmedia. 

Before creatng your own captons, learn about iTunes-compatble fle formats by 
reading “Creatng Content for iPod + iTunes” from Apple Educaton. Captons can be 
created using a number of diferent sofware packages. The table below shows several 
currently available applicatons. 

http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
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Table 1: Capton-creaton sofware

Name OS Cost Media formats Output

Annotaton Edit Mac OS X $300; 
free demo

MOV, MP4, M4V, 
others

SCC, QTText, others

CapScribe  Mac OS X Free MOV, MP4, AVI QTText, others

Hi-Capton  Windows Varies AVI, MOV, others QTText, RealText, 
SAMI, others

MAGpie  Mac OS X, 
Windows

Free MOV, AVI, WMV, RM QTText, RealText, 
SAMI, DFXP, plain text

MacCapton, 
CaptonMaker

Mac OS X, 
Windows

Varies Tape, MOV, MP4, 
others

Broadcast formats 
plus QTText, SCC, 
others

MovCaptoner Mac OS X $25 MOV, MP4, M4V, 
others

SRT, QTText, others

Subttle Workshop Windows Free AVI, WMV, others SRT, QTText, others

2.1: Captoning method

Providing synchronized captons is signifcantly diferent from merely providing a text 
transcript of the audio porton of the presentaton. (However, a text transcript is always 
recommended in additon to captons. Transcripts provide an easy way to scan a video’s 
script or to search for partcular terms. In iTunes, they can be uploaded as accessible PDF 
documents or included as metadata that travels with the clip itself. See below for 
details.)There are a number of applicatons you can use to create captons; several are 
shown in Table 1, above. Specifc capton-creaton processes will vary depending on the 
sofware used; however, the general workfow can be described as follows.

Enter capton text into the editor

Capton text can be entered by transcribing directly into the editor or, in many cases, by 
importng an electronic script. The later is generally more efcient than the former, but 
this may vary depending on the applicaton.

Edit and break text into captons

Once you have entered text into the capton editor, you can edit as necessary, correct 
spelling errors and divide or combine blocks of text to create smaller or larger captons. 
Normally, each capton will contain one, two or three rows of text.

Time the captons

Once the text has been edited and formated, you’ll assign a tmecode to each capton 
that indicates when it will appear or disappear from the screen. How you do so will 
depend on the sofware you’re using, but it’s generally as simple as pressing a buton on 
the keyboard or clicking one on-screen. In most cases you’ll fnd that one capton will 
follow another without pause, but you will also have the opton to erase the capton 
display when there is a break in the narraton or dialog.

http://www.urusoft.net/products.php?cat=sw&lang=1
http://www.synchrimedia.com/
http://www.ccaption.com/#http://www.ccaption.com/
http://www.ccaption.com/#http://www.ccaption.com/
http://ncam.wgbh.org/webaccess/magpie/
http://www.hisoftware.com/
http://www.capscribe.ca/
http://www.zeitanker.com/
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Review your work

Misspelled or poorly edited and tmed captons will only make it harder for the viewer to 
keep up with what’s happening on-screen, so accuracy in captoning is paramount. In 
most capton-editng sofware, you’ll be able to make changes to both text and tming as 
you spot errors. If possible, have someone else review your work when you are done.

Export a capton fle and add the captons to the video

When you’re satsfed with your work, your captoning sofware will allow you to export 
the captons in various formats. In iTunes, you can use either QTText or SCC. See the next 
secton for details on adding the captons to the video itself.

Create a transcript

Once you’re fnished captoning your video, create a transcript and upload that to iTunes 
U along with the video. Transcripts are useful for everyone: before taking the tme to 
download a video, a user can scan the transcript to see if the video is worth retrieving. 
They’re also searchable, can be printed or e-mailed and can be used as a reference tool.

Transcripts can be supplied as accessible PDFs; be sure to read Part 5 before you upload 
the fle. They can also be added as metadata using the Lyrics pane; read “Creatng 
Content for iPod + iTunes” to learn how to paste text into the Lyrics pane for this 
purpose. 

2.2: Appearance and positon of captons on the screen

What captons look like in iTunes multmedia will depend on the format you choose. SCC 
closed captons look very similar to NTSC broadcast closed captons, and characteristcs 
such as font face, size or background are determined by the device decoding the capton 
data. They are always positoned over the video region, and the author can choose to 
place them on the screen in various locatons (e.g., lef, right, center, top, botom) to 
indicate who is speaking or to avoid covering important on-screen graphics or acton. 
Finally, they can display a maximum of 32 characters per capton row. QuickTime Player, 
iTunes, iPhone and iPod nano can decode SCC captons; all ofer a convenient built-in 
interface to turn the captons on and of (see Appendix 2). Here’s a picture of SCC 
captons playing in iTunes:

http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
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If you want complete control over font characteristcs, QTText captons can be created in 
nearly any font (keep in mind that some fonts are more readable as captons than 
others), color, weight or size. In most cases, however, authors use a light-colored font 
over an opaque (black) background, as demonstrated in the images below.
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The positon of the capton region (the box in which the captons are placed) can also 
vary. Most authors will place the capton region adjacent to the botom edge of the 
video region, as shown in the images above. However, QTText captons can also be 
positoned in an opaque region directly over the video, as shown below.

They can also be placed over the video in a translucent region, which allows viewers to 
see a bit of the movie behind the capton background...
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...or in a transparent region over the video, which makes the captons appear to foat 
over the video, as shown below.

Finally, the placement of QTText captons within the capton region is variable. In many 
cases, authors will place the captons in the center of the region, as seen here.
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You can also move the captons to one side to indicate who is speaking:

Or you can leave them in the center and simply identfy who is speaking:

In most cases, QTText captons integrated into iTunes multmedia are open—that is, they 
are merged with the video track and cannot be turned of. If you want QTText captons 
to be closed, you’ll need to create a wired sprite to add a custom capton-toggle 
interface to the movie (see Appendix 1 as well as Part 1.5). Wired sprites can be 
operated only when the movie is played using QuickTime or iTunes. A movie with wired 
sprites cannot be used on iPod.
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2.3: Consideratons for writng captons 

Captons are not difcult to create, but capton writng can be tme-consuming, 
especially for those new to the process. For example, someone with experience 
might be able to write, edit, review and output captons for a 10-minute clip in 
approximately 45 minutes, whereas the same clip captoned by a new user might take 2 
hours or more to create. The speed at which a clip can be captoned will vary depending 
on a number of factors, such as the author’s typing speed and command of English. An 
electronic script or transcript of the program audio, which is usually prepared as part of 
the general producton process, is a valuable tme-saver because it can be imported into 
most captoning applicatons, thereby eliminatng the need to transcribe the audio from 
scratch.

Someone with excellent writng, spelling and listening skills can write captons. 
Captoners should have adequate access to reference and support materials 
(dictonaries, textbooks, the Web, etc.) in order to ensure that the captons are as 
accurate as possible. Ideally, the captons should be given a fnal review by someone 
other than the original writer.

When the workload is greater than in-house staf can support, it would be wise to 
consider sending the multmedia to a vendor who can create captons in a tmely 
manner. Rates for this service will vary widely depending on the length of the material, 
formats required, turnaround tme, etc. A short list of major vendors can be found in 
Appendix 4.

2.4: Creatng SCC closed captons 

As discussed earlier, a main advantage of SCC captons is that they make use of built-in 
capton controls in QuickTime Player, iTunes, iPhone and iPod nano, giving users easy 
access to the captons at all tmes. Currently, SCC capton fles can be exported directly 
from zeitAnker’s AnnotatonEdit, CPC’s CaptonMaker and MacCapton. You can also use 
free sofware such as MAGpie to write the inital QTText capton fles, then use Subttle 
Workshop to convert the fles to SRT. The SRT fles can be then converted to SCC using 
free command-line tools. MovCaptoner or Subttle Workshop will also create SRT 
capton fles, which can then be converted to SCC. Check Table 1, above, for details on 
these and other capton-authoring applicatons. 

Once you have an SCC capton fle, you’ll add it to the movie using either QuickTime or 
Compressor (a component of Final Cut Studio), as described in Parts 2.5 and 2.6, 
respectvely.

http://www.apple.com/finalcutstudio/
http://www.apple.com/finalcutstudio/compressor/
http://www.apple.com/quicktime/
http://www.urusoft.net/products.php?cat=sw&lang=1
http://www.synchrimedia.com/
http://www.geocities.com/mcpoodle43/SCC_TOOLS/DOCS/SCC_TOOLS.HTML
http://www.urusoft.net/products.php?cat=sw&lang=1
http://www.urusoft.net/products.php?cat=sw&lang=1
http://ncam.wgbh.org/webaccess/magpie/index.html
http://www.cpcweb.com/nle/
http://www.cpcweb.com/nle/
http://www.zeitanker.com/content/tools/zeitanker_tools/zeitanker_annotation_edit/
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2.5: Using QuickTime to add SCC captons to video clips 

Follow the instructons below to use QuickTime to create SCC-captoned movies playable 
on desktop or mobile players.

1 Open the uncaptoned movie using QuickTime.

2 Choose File > Export, then choose Movie to iPod. Close the movie window when the 
export is fnished.

3 Open the exported movie in QuickTime. Set this window aside.

4 Open the SCC fle in a new QuickTime Player window. You should see the captons 
displayed over a white region, as shown in the picture below. If you don’t see captons, 
make sure the captons are turned on by choosing View > Show Closed Captoning.
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The default size of the SCC track is 640 x 480. If this isn’t the size of your source video, 
you’ll need to scale the track. Choose Window > Show Movie Propertes. In the tracks 
list, click Closed Capton Track, then click the Visual Setngs buton. In the Scaled Size 
felds, enter the height and width to match that of your source video. Depending on the 
size of the source, you may need to uncheck the Preserve Aspect Rato box. Below is an 
example.

Close the Movie Propertes window when you are done.

5 Select (Edit > Select All) and copy (Edit > Copy) the entre SCC capton track.

6 Switch to the uncaptoned M4V movie. Make sure the playhead is positoned at the 
beginning of the movie, then choose Edit > Add to Movie.

7 Play the movie. If you don’t see captons, make sure the captons are turned on by 
choosing View > Show Closed Captoning. Below is an image showing SCC captons 
playing in QuickTime Player.
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8 Move the playhead to the beginning of the movie, choose File > Save, and save the fle 
as a self-contained movie. (It will be saved with the MOV fle extension, but it will stll be 
playable on iPhone or iPod.)

Your SCC closed-captoned movie is now ready to be uploaded to iTunes U. 

2.6: Using Compressor to add SCC captons to video clips

Compressor is a component of Final Cut Studio. If you’re already using Final Cut Studio 
to prepare your movies for iTunes, you will fnd it very convenient to add SCC capton 
fles with Compressor. Note that Compressor does not create SCC captons. Instead, it 
takes existng SCC fles and encodes them into movies. See Part 2.4 to learn about 
creatng SCC fles, then follow the instructons below to add them to your movies.

1 Open the uncaptoned video fle(s) in Compressor.

2 In the Batch window, apply the appropriate output setngs (e.g., H.264 for iPod video 
and iPhone).

3 Click the job to which you want to add captons.

4 In the Inspector window, click the Additonal Informaton tab, as shown below.
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5 Click the Choose buton and browse to the SCC fle.

6 Click the Submit buton in the Batch window to start the compression.

When the compression is fnished, your SCC closed-captoned movie will be ready to 
upload to iTunes U. 

2.7: Adding QTText captons to video clips

The instructons below will show you how to merge QTText captons with the source 
video, creatng an open-captoned movie. If you want your QTText-captoned 
presentaton to play on all devices, open captons are currently the best opton. If you 
want closed QTText captons, you’ll need to add wired sprites to toggle the captons on 
and of, but bear in mind that these controls can only be used in QuickTime and iTunes 
(see Part 1.5). See Appendix 1 to learn about using wired sprites. 

1 Open the QTText fle in QuickTime Player. The fle opens as a capton track, as shown 
below.
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2 Select (Edit > Select All) and copy (Edit > Copy) the entre track.

3 Open the original (uncaptoned) video in a new QuickTime window.

4 Place the playhead at the beginning of the movie, then choose Edit > Add to Movie. The 
capton track appears at the top of the video region, as shown below.

5 Open Window > Show Movie Propertes. Double-click Text Track, enter a more 
descriptve name (e.g., captons) and press Return.

6 Click the Visual Setngs buton.

7 Repositon the capton region: in the Ofset area, enter the new positon. The frst entry 
is the X (horizontal) positon; the second entry is the Y (vertcal) positon. For example, if 
the source video is 400w x 300h, and you want the top of the capton region to be 
positoned at the botom edge of the video region, enter an ofset of 0 x 300, as shown 
below.
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8 Close the Movie Propertes window.

9 Move the playhead to the beginning of the movie, choose File > Save As, and save the 
fle as a self-contained movie. 

10 Choose File > Export and export as Movie to QuickTime Movie. This will create an open-
captoned movie—the text track will be combined with the video track so the captons 
cannot be turned of. 

11 Open the exported movie in a new QuickTime window, choose File > Export, then 
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choose Movie to iPod. 

Your QTText open-captoned movie is ready to be uploaded to iTunes U.

2.8: Displaying QTText captons over a transparent background

Instead of placing the capton region below the video region, as described above, it is 
possible to display captons directly over the video region using a transparent 
background. This can be useful for saving space on the screen, for example, since placing 
the capton region outside the video region can enlarge the size of the presentaton as a 
whole. 

To embed transparent-background captons, frst create a QTText capton fle (described 
in Part 2.3). You must then add QuickTime descriptors to the header (the bracketed 
informaton at the top of the capton fle), as detailed below. 

1 Open the QTText fle in a text editor, such as TextEdit or Notepad. 

2 In the header, add {keyedText:on}. This will create the transparent capton region.

3 To improve the legibility of the text, add a drop shadow to the captons by adding 
{dropShadow:on} to the header. To adjust the characteristcs of the drop shadow, use 
{dropShadowOfset:X,Y}, where X specifes the number of pixels to ofset the shadow to 
the right, and Y specifes the number of pixels to ofset the shadow down. Values of 1,1 
are ofen sufcient. 

4 Adjust the height of the capton region by changing {height=X} in the header, where X 
represents the height of the region in pixels. Depending on the font size you’re using, a 
height specifcaton of 40–80 is generally sufcient. If your header doesn’t have a 
{height} descriptor, add it now.

5 Specify the color of the text by adding {textColor:R,G,B} to the header, where R=red, 
G=green and B=blue. Each value can range from 0–65535.

6 Smooth the edges of the text by adding {ant-alias:on}.

http://www.apple.com/quicktime/tutorials/textdescriptors.html
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7 Embed the track as described in Part 2.7. When ofsetng the capton track, positon the 
capton region near the botom edge of the video region, as shown below.

Read about QuickTime descriptors to learn more about what you can do with QTText 
tracks.

2.9: Displaying QTText captons over a translucent background 

To embed translucent-background captons in your movie, frst create a QTText capton 
fle (described in Part 2.3), then follow the steps below.

1 Open a text editor, such as TextEdit, and create a capton-background track by entering 
the following text:

{QTtext}{timescale:100}{width:400}{height:57}

[00:00:00.00]

[00:00:36.20]

The last tmecode shown above ([00:00:36.20]) should be altered to represent the entre 
length of your movie. Also change the {width} descriptor to match the width of your 
movie, and the {height} descriptor to accommodate the maximum number of rows in a 
capton. Depending on the font size, a height specifcaton of 40–80 is usually sufcient. 
Do not enter capton text, or any other text, in this fle. 

2 Save the fle with the extension .txt (e.g., mask.txt). Quit the text editor and then open 
this .txt fle in QuickTime. This track will become the background for the captons.

http://www.apple.com/quicktime/tutorials/textdescriptors.html
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3 Embed this background track into the original movie, as described in steps 2-7 of Part 
2.7. Note that the background track will appear solid black, positoned at the top of the 
video region, as shown in the image below.

4 Choose Window > Show Movie Propertes. Double-click Text Track, type a more 
descriptve name (e.g., mask) and press Return. 

5 Click the Visual Setngs buton.

6 From the Transparency pop-up menu, choose Blend. Move the Transparency Level slider 
lef or right to adjust the transparency of the background. Below is an image showing 
the slider at approximately 30% transparency.
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7 Repositon the mask region: in the Ofset area, enter the new positon. The frst entry is 
the X (horizontal) positon; the second entry is the Y (vertcal) positon. Positon the mask 
region so the botom edge just touches the botom edge of the video region. 

8 Close the Movie Propertes window, set the movie aside but do not close the player 
window.

9 Open the QTText capton fle in a text editor and add QuickTime descriptors as discussed 
in steps 1-6 in Part 2.8. (You may fnd that it isn’t necessary to include {dropShadow} 
when embedding translucent captons.) Close the text editor when you’re fnished.

10 Open the QTText capton fle in a new QuickTime window. Select (Edit > Select All) and 
copy (Edit > Copy) the entre track.

11 Click the movie that contains the mask track. Embed the capton track as described in 
Part 2.7. When ofsetng the capton track, make sure all the captons ft inside the 
mask, as shown in the image below. If you fnd that the captons don’t ft properly, adjust 
the {height} in the capton fle’s header. 

2.10: Adding SCC captons to audio clips

When adding SCC captons to an audio-only clip you must include a video track for the 
captons to be visible. This video track can be a statc image (a university logo, 
for example) layered in the movie so it appears behind the captons. Here’s how it’s 
done.

1 Create SCC captons as described in Part 2.4.

2 Open the original (uncaptoned) audio fle in a QuickTime window. Choose File > Export 
and export it as Movie to iPod, and close the window.
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3 Open the exported audio fle in QuickTime and set this window aside.

4 Open the SCC fle in a new QuickTime Player window. You should see the captons 
displayed over a white region, as shown in the picture below. If you don’t see captons, 
make sure the captons are turned on by choosing View > Show Closed Captoning.

The default size of the SCC region is 640 x 480. You can scale this to a smaller size, such 
as 320 x 240, but anything smaller may decrease the readability of the capton text. To 
scale the region, choose Window > Show Movie Propertes. In the tracks list, click Closed 
Capton Track, then click the Visual Setngs buton. In the Scaled Size felds, enter the 
new height and width. Close the Movie Propertes window when you’re fnished.

5 Select (Edit > Select All) and copy (Edit > Copy) the entre track.

6 Switch to the uncaptoned audio fle. Make sure the playhead is positoned at the 
beginning of the movie, then choose Edit > Add to Movie.

7 Play the movie. If you don’t see captons, make sure the captons are turned on by 
choosing View > Show Closed Captoning. Set this window aside.

8 Open the image you want to use as a background in a new QuickTime window. Choose 
File > Export, then choose Movie to iPod.

9 Open the exported image in QuickTime. Select (Edit > Select All) and copy (Edit > Copy) 
the entre track.

10 Switch to the captoned audio track. Make sure the playhead is at the beginning of the 
movie, then choose Edit > Add to Selecton & Scale.

11 Drag the playhead to a point in the movie where captons should appear and choose 
View > Show Closed Captoning (you won’t see captons at this point, however).

12 Choose Window > Show Movie Propertes.

13 Click Closed Capton Track, then the Visual Setngs buton.
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14 Next to the Layer edit feld, click the arrows untl you see captons appear in the player 
window (you should only have to move one or two layers). You’ll see something similar 
to the images below.

15 Close the Movie Propertes window.

16 Play the movie. You should see SCC captons playing over the background image you 
chose. 

17 Move the playhead to the beginning of the movie, choose File > Save As, and save the 
fle as a self-contained movie. Note that it will be saved with the MOV fle extension, but 
it will stll be playable on iPhone or iPod.

Your SCC-captoned audio clip is now ready to be uploaded to iTunes U. Watch a sample 
SCC-captoned audio clip.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083381246?i=2006531385
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083381246?i=2006531385
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2.11: Adding QTText captons to audio clips 

The instructons below will show you how to merge QTText captons with the source 
audio fle, creatng an open-captoned audio clip. If you want your QTText-captoned 
presentaton to play on all devices, open captons are currently the best opton. If you 
want closed QTText captons, you’ll need to add wired sprites to toggle the captons on 
and of, but bear in mind that these controls can only be used in QuickTime and iTunes 
(see Part 1.5). See Appendix 1 to learn about using wired sprites.

An important point to note is that you must include a video track in order for the 
captons to be visible. If no video track is present, the captons will not survive the 
export process described below. This video track can be a statc image (a university logo, 
for example) that is visible behind the capton layer, or it can be an image scaled to a 
small size and layered in the movie so it is essentally invisible. The example below 
illustrates the later.

1 Write the captons and export a QTText fle (see Part 2.3). 

2 Open the original (uncaptoned) audio clip in a QuickTime window and set this window 
aside.

3 Open the QTText fle in a separate QuickTime window.

4 Select (Edit > Select All) and copy (Edit > Copy) the entre track.

5 Switch to the uncaptoned audio fle. Make sure the playhead is positoned at the 
beginning of the movie, then choose Edit > Add to Movie.

6 Play the audio fle; you should see captons over a black region, as shown below. Set this 
window aside.

7 Open an image in a new QuickTime window. The content doesn’t mater because it will 
become invisible later. 

8 Chose Window > Show Movie Propertes. Click Video Track in the track list and then click 
the Visual Setngs buton.
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9 Just below the Scaled Size felds, uncheck Preserve Aspect Rato. In the Scaled Size felds, 
replace the width to match the width of the captoned audio clip, and enter the height 
as 1. Below is an example.

You’ll wind up with a visible region that is only one pixel in height, similar to the one 
below.

10 Close the Show Movie Propertes window.

11 Select (Edit > Select All) and copy (Edit > Copy) the entre track.

12 Switch to the player containing the captoned audio clip. Make sure the playhead is 
positoned at the beginning of the clip, then choose Edit > Add to Selecton & Scale. You 
should see the image appear at the top of the capton region.

13 Choose Window > Show Movie Propertes and click Video Track in the track list, then 
click the Visual Setngs buton. 
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14 Next to the Layer feld, click arrow butons untl you see the image disappear from the 
player window. (It’s not actually disappearing; it’s simply moving behind the capton 
layer.) You should only have to move one or two layers.

15 Move the playhead to the beginning of the movie, choose File > Save As and save the fle 
as a self-contained movie. 

16 Choose File > Export and export as Movie to QuickTime Movie. This will combine the 
tracks and create an open-captoned audio clip. 

17 Open the exported movie in QuickTime, choose File > Export, then choose Movie to 
iPod. 

Your QTText open-captoned audio clip is ready to be uploaded to iTunes U. Watch a 
sample QTText-captoned audio clip.

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083349866?i=1889003114
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2083349866?i=1889003114
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Part 3:  Adding Foreign-Language Subttles to iTunes 
Multmedia
Foreign-language subttles will make your iTunes multmedia more versatle and allow 
you to expand the reach of your materials. In many cases, you’ll fnd that QTText tracks 
are adequate for subttles. Resist the temptaton to create subttles using SCC tracks. If 
you use SCC tracks for subttles, you’ll confuse your audience: deaf viewers will expect to 
see captons when they actvate the capton toggle, not foreign-language subttles. You’ll 
also lose the ability to include both closed captons and subttles in your movie.

3.1: Adding QTText subttles to iTunes multmedia

The steps for integratng QTText subttles into your video are identcal to those for 
captons. See Part 2, Table 1, to learn which captoning applicatons create QTText fles. 
Once you’ve writen and exported the text fles, follow the directons in Parts 2.7, 2.8 or 
2.9 for adding the subttles to your video, depending on the style you want to use. In the 
Show Movie Propertes window, be sure to name the text tracks logically (e.g., French, 
German, Italian, etc.) so you can easily identfy them.

Your movie can accommodate multple text tracks, but this will require the use of wired 
sprites to toggle each track on and of. As discussed in Part 1.5, these sprites can only be 
used in QuickTime Player and iTunes, not iPhone or iPod. See Appendix 1 for for 
instructons on adding wired sprites. 

3.2: Adding closed subttles to iTunes multmedia

Movies in the M4V format can carry closed subttle tracks tagged with special metadata 
that allows them to be recognized and decoded by QuickTime Player, iTunes, iPhone and 
iPod touch. These devices give users access to the closed subttles through menus or on-
screen controls. This subttle format has some limitatons to keep in mind should you 
choose to implement it: the text can’t be styled, and the placement of the subttles 
within the player varies depending on the playback device (iPhone and iPod touch place 
them at the botom of the screen; iTunes and QuickTime place them at the top). To see 
what they look like, watch a sample clip with closed foreign-language subttles.

You’ll need to use several diferent tools to integrate the closed-subttle data into your 
movie. A Windows computer is required for some processes, and you should be 
comfortable using the command-prompt window. 

Before beginning, download and install the following sofware:

• MP4Box   (Windows only). For simplicity, install it in the same directory as the source 
media and subttle fles.

• Dumpster   (Windows). Mac users can download QuickTime Movie Atom Dumpster.

• Captoning sofware that creates SubRip (SRT) fles (see Part 2, Table 1). You can also 
use MAGpie to write the inital QTText subttle fles and Subttle Workshop to convert 
these fles to SRT. 

http://www.urusoft.net/products.php?cat=sw&lang=1
http://ncam.wgbh.org/webaccess/magpie/index.html
http://developer.apple.com/quicktime/quicktimeintro/tools/
http://developer.apple.com/quicktime/quicktimeintro/tools/
http://www.videohelp.com/tools/mp4box
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084233176?i=1362085531
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Once the sofware is installed, begin by creatng the subttle fle.

1 Write the subttles. The process is similar to the captoning method described in Part 2.3. 
Do not apply any styles (color, size, font type, italics, etc.).

2 Export the fle as SRT. If you’re using MAGpie, frst export the fle as QTText, then open 
this fle in Subttle Workshop and save it as an SRT fle.

3 On a Windows computer, copy the SRT fle into the directory containing MP4Box.exe.

4 Repeat this process for each track of subttles.

Next, convert the source video to M4V. 

1 Open the movie in QuickTime.

2 Choose File > Export and export as Movie to iPod.

3 Copy the exported movie to the same directory as MP4Box.exe.

Now convert the SRT fles to the TTXT format.

1 Open a command-prompt window and change to the directory that contains 
MP4Box.exe.

2 Convert the SRT fles to TTXT fles by typing (no quotes) “mp4box -txt flename.srt”, 
where “flename.srt” is the SRT subttle fle you want to convert.

3 Repeat for each SRT fle.

Next, integrate each TTXT fle into the source M4V.

1 At the command prompt, type (no quotes) “mp4box -add 
flename.txt:lang=threeDigitLanguageCode targetMovieName.m4v”, where 
“flename.txt” is the name of the TTXT fle you created in the previous step; 
“threeDigitLanguageCode” is the three-digit ISO code representng the track’s language; 
and targetMovieName.m4v is the name of the video to which you are adding the 
subttles.

2 Repeat for each TTXT fle.

When you have integrated all the TTXT fles into the movie, drag the M4V onto the 
Dumpster icon. Double-click ‘moov’. The subttle tracks you added to the movie can be 
found at the end of the ‘trak’ list. For example, if you added four subttle tracks they will 
be the last four ‘trak’ entries. With this in mind...

1 Double-click the frst ‘trak’ that corresponds to your frst subttle track.

2 Double-click ‘tkhd’.

3 Change Flags to $000001.

4 Click the Apply buton at the botom of the window (you must click Apply afer you 
make each change described here or your changes will not be saved).

5 Change Alternate Group to $0002.

6 Double-click ‘tkhd’ to close.

7 Double-click ‘mdia’.

8 Double-click ‘hdlr’.

http://www.loc.gov/standards/iso639-2/php/code_list.php
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9 Change Component subtype to $7362746c (this will change the type to ‘sbtl’).

10 Double-click ‘hdlr’ to close.

11 Repeat the above steps for each ‘trak’ that corresponds to a subttle track, but leave all 
other ‘tkhd’/Flags set to $000000. Be sure to click the Apply buton at the botom of the 
window afer you make each change. When you have fnished altering all tracks, close 
Dumpster. Next, check your movie in iTunes.

1 Open the movie in iTunes.

2 Hover the pointer over the player so that the control bar appears.

3 Click the bubble icon once and you should see an alphabetcal list of your subttle tracks, 
as shown in the following image. 

4 Choose a language from the menu and the subttles will appear at the top of the video 
region, as seen below.
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5 If any subttle tracks are missing from the menu, close iTunes, reopen the M4V in 
Dumpster and verify that you have set all the fags, groups and component subtypes 
exactly as specifed above.

6 Transfer the movie to iPhone or iPod touch. Open the movie on the iPod touch and tap 
the screen once to reveal the video controls. Tap the bubble icon; you should see a list of 
languages appear, as shown below.

7 Choose a language and tap Done.

8 Play the movie. The subttles will appear at the botom of the video region, as shown 
below.
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If you’re playing the movie with QuickTime Player, the subttles can be accessed through 
the View > Subttles menu, as shown below.
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Part 4:  Creatng Audio Descriptons for iTunes Multmedia
When audio descriptons are absent from multmedia, blind or visually impaired users 
must depend on friends, family members, teachers or others to obtain relevant visual 
informaton from video clips. The techniques discussed in this secton will show you how 
to add audio descriptons to your iTunes multmedia. Before creatng your own 
descriptons, learn about iTunes-compatble audio fle formats by reading “Creatng 
Content for iPod + iTunes” from Apple Educaton.

4.1: Integraton of descriptons into multmedia

Audio descriptons should be carefully writen to ft into the natural pauses in the 
program dialog. In cases where a longer descripton is necessary but there is not a 
sufcient pause in the program audio to accommodate it, you can integrate extended 
audio descriptons into the movie. In this situaton, the program dialog and video appear 
to automatcally pause while a long audio descripton plays. When the descripton has 
fnished playing, the video and dialog resume playback. Extended and “regular” 
descriptons may be mixed in a single multmedia presentaton. You can watch a brief 
example of a video clip with regular descriptons as well as a video clip with extended 
descriptons.

When descriptons are integrated into television programs or movies, sound engineers 
are careful to lower, or “duck,” the program audio when the descripton is playing so the 
descripton can be heard clearly, and then raise the program audio level when the 
descripton has fnished. In iTunes multmedia, ducking will only be possible if you use a 
sound-editng applicaton to add the descriptons directly to the program audio track. 
This adds tme to your producton tmeline but, depending on your goals, may be 
necessary if you want to produce a professional-level presentaton. Even if you don’t 
duck the sound levels, you can stll create an efectve described presentaton. Just note 
that you may have to boost the descripton’s sound level when you create and process 
the fle to be sure it can be heard over the program audio. 

A fnal point to consider is that you need not always supply a video track with the 
described audio. The descriptons can be integrated into the movie and then the entre 
audio porton of the presentaton can be saved with open descriptons and extracted to 
a separate audio fle. This audio fle can then be uploaded to iTunes. Users can download 
just the audio (saving both tme and bandwidth) and listen to it on any player, including 
an audio-only device such as iPod shufe.

4.2: Consideratons for writng descriptons 

Ideally, describers should have excellent writng skills and a frm command of the 
vocabulary associated with the subject, as well as adequate access to reference and 
support materials, such as dictonaries, relevant textbooks, the Web, etc., in order to 
ensure that the descriptons are as clear and accurate as possible. As a fnal quality-
control mechanism, the descriptons should always be reviewed by someone other than 
the original writer. 

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084821091?i=1280067030
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084821091?i=1280067030
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084757097?i=1688519967
http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
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Accurately and succinctly describing visual elements poses numerous challenges. The 
Carl and Ruth Shapiro Family Natonal Center for Accessible Media (NCAM) has created a 
set of guidelines for describing images in science textbooks and related materials; you’ll 
fnd helpful informaton there regardless of your subject mater. Always ensure that the 
descriptons convey as much informaton as necessary without being overly long. 
Describe all important details thoroughly, such as scenery and actons, scientfc and 
mathematcal expressions, or graphs and charts, and use a vocabulary that is 
appropriate to the subject mater or intended audience. 

Descriptons should be added to a presentaton once the video and audio elements have 
been completed. Waitng to author descriptons untl the end of the producton process 
will ensure that they accurately refect the program visuals. If you must re-edit the video 
or audio afer the descriptons have been created, you may have to re-record the 
descriptons as well. 

If you want your described presentaton to play on all devices, open descriptons are 
currently the best opton. Note that iTunes, iPhone and iPod touch (OS 3.x) do, in fact, 
have the capability to toggle alternate audio tracks on and of via menus or the on-
screen controller. QuickTime, iPod nano and Apple TV do not yet support this feature, 
although they may do so in the future. If you choose to integrate closed audio 
descriptons, you should also create a version with open descriptons so viewers with 
other playback devices can download that video and hear the described audio. See Part 
4.8 for complete details.

Another approach to closed descriptons is to add wired sprites to toggle the described 
audio on and of, but bear in mind that these controls can only be used in QuickTime 
and iTunes (see Part 1.5). See Appendix 1 to learn about adding wired sprites to your 
presentaton. 

4.3: Descripton method

There are a number of ways to write and record descriptons. The most straightorward 
method is to use a text processor to write a descripton script, then use QuickTime to 
both record the audio fles and add the descriptons to the original video. NCAM’s free 
multmedia-accessibility applicaton, MAGpie, also allows authors to write descripton 
scripts, record them and output them for integraton with iTunes multmedia. See 
MAGpie’s documentaton for complete details on usage and techniques for creatng 
audio-descripton fles. You can also use any sound-editng applicaton, such as Audacity, 
GarageBand, Logic or Sound Forge to record the fles. For the best results, record the 
descriptons in a quiet environment using a high-quality microphone. To minimize errors 
or ambiguity, speak clearly and read from a writen script. 

Here is a summary of the basic steps required for recording and integratng audio 
descriptons into iTunes multmedia. 

Watch the video and note opportunites for descriptve narraton

Watch the entre presentaton to determine where there are pauses in the dialog or 
narraton for inserton of descriptons. This will also help you become familiar with the 
general pacing of the program material as well as the language level, vocabulary and 
knowledge the producer has assumed on the part of the viewer. While watching, keep 
notes indicatng where descriptons will be inserted.

http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/logicstudio/logicpro/
http://www.apple.com/ilife/garageband/
http://audacity.sourceforge.net/
http://ncam.wgbh.org/webaccess/magpie/magpie_help/
http://ncam.wgbh.org/webaccess/magpie/index.html
http://ncam.wgbh.org/publications/stemdx/
http://ncam.wgbh.org/
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Write the descriptons

Time the pause where your frst descripton will be inserted, then use a text editor or an 
applicaton such as MAGpie to write the descripton to ft within that interval. Read the 
descripton while tming it to make sure it fts within the pause; edit as necessary and re-
tme. Repeat for subsequent descriptons.

Record the descriptons

Using QuickTime, MAGpie or any sound-recording sofware, record and edit the 
descriptons. Time them and re-record as necessary. 

Integrate the descriptons into the video

If you’re planning to integrate regular descriptons, use QuickTime to add them to the 
movie. If you’re adding extended descriptons, you’ll also need to do some video 
manipulaton with QuickTime. These techniques are detailed below.

Review your work; save and upload the clip

Watch the completed movie to make sure the descriptons play at the proper points in 
the tmeline, are clearly writen and appropriately descriptve. If you’re using extended 
descriptons, make sure that the video stops and restarts accurately. Re-record and re-
integrate descriptons as necessary. 

4.4: Sample method of recording descriptons

The easiest way to record audio-descripton fles is to use QuickTime. First, write the 
descriptons. When you’re ready to record them, follow the steps below.

1 Open QuickTime and choose File > New Audio Recording.

2 Plug a microphone into your computer, click the red Record buton in QuickTime Player 
and make a test recording. Play it back and listen carefully to ensure your voice was 
recorded at an appropriate level relatve to the program audio of the movie. Make 
adjustments as necessary untl you’re happy with the quality of the audio.

3 Place a printed or electronic copy of the descripton script where you can easily see it, 
click the red Record buton in QuickTime Player and speak into the microphone. When 
you’re fnished, click the buton again to stop recording.

4 Listen to the recording; re-record if necessary. When you’re satsfed with the recording, 
save the fle. 

5 Record the remaining descriptons.

Any extraneous noise at the beginning and end of the audio clip—mouse or keyboard 
clicks, paper rustling, breathing, etc.—can be easily deleted. You can do this as you 
create each audio fle, or you can wait untl you’ve recorded them all and then edit them 
all at once.

1 Open the audio fle in QuickTime.

2 Positon the playhead at the beginning of the movie and press I to mark the in-point of 
the segment you’re going to cut.

3 Move the playhead to the point in the tmeline immediately before you hear the 
descripton audio begin.
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4 Press O to mark the out-point of the segment you’re going to cut. You will see the 
segment defned in the tmeline, as shown in the image below.

5 Press the Delete key to erase this segment.

6 Move the playhead to the point in the tmeline immediately afer the descripton audio 
ends and press I.

7 Move the playhead to the end of the movie and press O. You will see this new segment 
defned in the tmeline, as shown below.

8 Press the Delete key to erase this segment.

9 Save the fle; edit the remaining descriptons in a similar manner.

If you prefer, you can use MAGpie or any sound-editng applicaton to record and edit 
your descriptons. No mater how you do it, it’s most efcient to record and edit all the 
descriptons before you integrate them into the video, rather than recording, editng and 
integratng the fles one at a tme. 

4.5: Adding open descriptons to video: full-mix audio

Once you’ve recorded and edited the descriptons, you’re ready to make them part of 
the movie that will eventually be uploaded to iTunes U. Again, the most straightorward 
method is to use QuickTime.

1 Open the original, undescribed movie in QuickTime, then choose Window > Show Movie 
Propertes.

2 Open the frst audio-descripton sound fle in a new QuickTime window. Select (Edit > 
Select All) and copy (Edit > Copy) the entre sound clip.

3 Switch back to the video window. Positon the playhead at the end of the pause where 
the frst descripton will go. Press the O key to mark the out-point of the segment.
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4 Move the playhead backwards untl you reach the beginning of this pause. Press the I 
key to mark the in-point of the segment. This selects the segment of the movie clip that 
will receive the audio descripton. You’ll see something similar to the image below.

5 Choose Edit > Add to Movie. In the track list at the top of the Movie Propertes window, 
you will see that “Sound Track 2” is now one of the choices.

6 Play the clip to hear the narraton you’ve just inserted. If you want, you can undo the 
inserton by choosing Edit > Undo (or delete Sound Track 2 from the track list in Movie 
Propertes) and try again.

7 When you’re happy with the descripton, choose File > Save As, rename the clip and save 
the fle as a self-contained movie.

8 Repeat steps 2-6 to insert subsequent audio descriptons. Always remember to select 
the segment that will contain the audio descripton by frst defning the end point and 
then the beginning point. 

9 When all the descriptons have been added to the movie, save the fle and then choose 
File > Export and export it as Movie to QuickTime Movie. This will combine all the audio 
tracks (the program audio plus all the descriptons) into a single track, giving you an 
open-described movie.

10 Open the exported movie in a new QuickTime window, choose File > Export, then 
choose Movie to iPod.

Your open-described movie is now ready to upload to iTunes U.
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4.6: Adding closed descriptons to video: full-mix audio

If you want to add closed descriptons to your movie, one method is to embed both 
undescribed and described program audio tracks, then add wired sprites to switch 
between the two tracks (see Appendix 1) . Note that wired sprites will only work in 
iTunes and QuickTime, not on iPhone or iPod. See Part 1.5 for more informaton before 
you proceed. 

1 Create an open-described movie as outlined in Part 4.5. 

2 Choose Window > Show Movie Propertes.

3 From the track list, click the audio track once, then click the Extract buton. The 
extracted audio track will open in a new QuickTime window.

4 Select (Edit > Select All) and copy (Edit > Copy) the entre audio track.

5 Open the original, undescribed movie in QuickTime. 

6 Make sure the playhead is positoned at the beginning of the tmeline, then choose Edit 
> Add to Movie. 

7 Choose Window > Show Movie Propertes. In the track listng, you will see that “Sound 
Track 2” has been added to the list. Double-click this track and rename it (e.g., 
audiodesc).

8 Choose File > Save As and save the fle as a self-contained movie.

9 Add wired sprits as described in Appendix 1 to switch between the undescribed and 
described tracks.

4.7: Adding closed descriptons to video: descripton-only track

If you don’t want to embed two full audio tracks in your movie, you can instead create a 
track that contains only descriptons with periods of silence between each one, with the 
silence corresponding to portons of the program audio where the descriptons do not 
play. In other words, your movie will contain one track of program audio with no 
descriptons, and one track of descriptons with no program audio, both playing in 
parallel. You can then add a wired sprite as described in Appendix 1 to toggle the 
descripton track on and of, giving users a choice between hearing the descriptons or 
not. Read Part 1.5 before using wired sprites.

For this process, in additon to QuickTime, you’ll need a sound-editng applicaton such 
as Audacity, GarageBand, Logic or Sound Forge. Using the sound editor, you’ll 
simultaneously listen to the program audio track while recording descriptons into a new 
track, as described below. All sound editors are diferent; this informaton represents a 
general approach to recording a separate descripton track rather than one that applies 
to a specifc editor. For informaton on fle formats and how to prepare audio fles for 
iTunes, see “Creatng Content for iPod + iTunes.”

1 Write the descriptons and place a printed or electronic copy of the descripton script 
where you can easily see it.

2 Open the original, undescribed video in QuickTime.

http://images.apple.com/support/itunes_u/docs/iTunes_U_Creating_Content.pdf
http://www.sonymediasoftware.com/products/soundforgefamily.asp
http://www.apple.com/logicstudio/logicpro/
http://www.apple.com/ilife/garageband/
http://audacity.sourceforge.net/
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3 Choose Window > Show Movie Propertes.

4 From the track list, click Program Sound once, then click the Extract buton. This program 
audio track will open in a new QuickTime window.

5 Save this new audio track as a self-contained fle, close its window and then open this 
track in a sound editor. 

6 Open a new (empty) track in the sound editor, and positon it so you can easily see both 
it and the program audio track.

7 Confgure your editor to allow you to simultaneously listen to and record tracks. Set up 
your microphone and prepare to record your voice into the empty audio track. To 
prevent a feedback loop from occurring while you record, you’ll need to listen to the 
program audio track through headphones, not speakers.

8 Play the program audio and, at the appropriate points in the tmeline and without 
pausing the program audio playback, record the audio descriptons into the empty track. 
Don’t worry about extraneous noise between descriptons (breathing, paper shufing, 
etc.)—you’ll eliminate this in step 10, below.

9 If you make a mistake, you don’t have to re-record the entre descripton track. Just 
pause the playback, move the cursor back in the tmeline to a point just prior to the 
faulty descripton, click Play and re-record the descripton as described in step 8.

10 When you’re fnished recording, faten the soundwaves in the intervals between the 
descriptons, thereby creatng dead silence between the descripton audio. In most 
editors this is accomplished by selectng the interval, then lowering the audio level to 
zero. You can also replace the interval with silence, if the editor gives you this opton.

11 Trim the length of the descripton track to exactly match the program audio track.

12 Save the descripton track and close the sound editor.

13 Open the descripton track in QuickTime, then select and copy the entre track.

14 Switch to the window containing the original, undescribed movie. 

15 Make sure the playhead is positoned at the beginning of the movie, then choose Edit > 
Add to Movie. 

16 Choose Window > Show Movie Propertes. In the track list, you will see that “Sound 
Track 2” has been added to the list. Double-click this track and change the name (e.g., 
audiodesc).

17 Save the fle as a self-contained movie.

18 Add a wired sprite to toggle the descripton track on and of (see Appendix 1).

4.8: Adding closed descriptons that are accessible using system menus

iTunes, iPhone and iPod touch (OS 3.x) accommodate the inclusion of extra audio tracks 
in movies, and these tracks can be used to deliver audio in alternate languages. When 
properly labeled and integrated in the movie, these tracks can be turned on and of via 
menus or with the on-screen controller, providing a convenient method to access closed 
audio descriptons. Please note that some other playback methods—QuickTime Player, 
iPod nano and Apple TV—do not currently provide a way to access extra audio tracks 
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although they may do so in the future. If you choose to integrate closed audio 
descriptons, you should also create a version with open descriptons so viewers with 
other playback devices can download that video and hear the described audio. Watch a 
brief video with closed descriptons that can be accessed using iTunes, iPhone or iPod 
touch.

To add closed-descripton tracks, frst record the descriptons as described in Part 4.4, 
then integrate open descriptons into the video using the method described in Part 4.5. 
When you’ve fnished adding the descriptons, follow the instructons below.

1 Open the original, undescribed video in QuickTime. Choose File > Export, then choose 
Movie to iPod. Close the original video, then open the newly exported video in a new 
QuickTime window. Set this window aside.

2 In QuickTime, open the video containing the open-described track. 

3 Choose Window > Show Movie Propertes. Click the audio track once to highlight it, as 
shown in the following image, then click the Extract buton in the upper-lef corner of 
the window. 

4 The extracted audio track will open in a new QuickTime window. Select (Edit > Select All) 
and copy (Edit > Copy) the entre sound clip.

5 Switch to the undescribed video and choose Window > Show Movie Propertes. In the 
player window, positon the playhead at the beginning of the tmeline, then choose Edit 
> Add to Movie to add the audio track with descriptons to the movie.

6 In the Show Movie Propertes window, double-click each of the audio tracks and rename 
them with names that refect their content: e.g., “Audio without descriptons” and 

http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2254367211?i=1101365952
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2254367211?i=1101365952
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“Audio with descriptons.” 

7 Uncheck the track that contains the descriptons, as shown below, and ensure that the 
undescribed track is checked. This will make the undescribed track the default audio 
when the movie is played.

8 Click the undescribed audio track, then click the Other Setngs buton. From the 
Language pop-up menu, choose English. From the Alternate pop-up menu, choose the 
track with descriptons, as shown in the image below.
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9 Click the described audio track, then click the Other Setngs buton. From the Language 
pop-up menu, choose English. From the Alternate pop-up menu, choose the track 
without descriptons.

10 Close the Show Movie Propertes window and save the fle as a self-contained movie. (It 
will be saved with the MOV fle extension, but it will stll be playable on iPhone or iPod.)

11 Check your work by opening the movie in iTunes. Choose Controls > Audio & Subttles. 
You will see the two audio tracks listed in the submenu, as shown below. The 
undescribed track will be the default. To switch to the described track, simply choose it 
from the menu.

Alternatvely, roll the pointer over the video window to reveal the playback controls. 
Click the balloon image once and choose a track from the list, as shown below.
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12 To check the video on iPhone or iPod touch, sync the device with iTunes and then open 
the movie. Tap the screen to reveal the controls, then tap the alternate-language balloon 
that is visible on the lef edge, as seen below.

13 Choose the audio track from the Language menu, seen in the image below, then tap 
Done.
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4.9: Embedding extended descriptons in video

In cases where a lengthy descripton is necessary but there is not a sufcient pause in 
the program audio to accommodate it, consider using extended audio descriptons. In 
this situaton, the video and program audio will appear to automatcally pause while a 
long audio descripton plays. (Note that you’re not actually pausing the video—instead, 
you’re playing a stll-frame for the duraton of the extended descripton.) When the 
descripton has fnished playing, the video and program audio resume playback. 
Extended descriptons are open—that is, everyone will hear them. The process for 
integratng them into a movie is explained below. 

1 Record and edit the extended descriptons. You can use QuickTime (see Part 4.4) or any 
other sound-recording applicaton.

2 Open the frst extended descripton in QuickTime and set this window aside.

3 In a new QuickTime window, open the original, undescribed movie.

4 Move the playhead to the exact point in the movie where you want the video to pause 
and the frst extended descripton to play.

5 Choose File > Export, choose Movie to Picture from the Export list and choose 
Uncompressed from the Use list. This will export the single frame that is currently in 
view. Give the frame a name and click Save.

6 In a new QuickTime window, open the image fle you created in step 5. 

7 Select (Edit > Select All) and copy (Edit > Copy) the entre track.

8 Switch to the window containing the frst descripton. Choose Edit > Select All.

9 Choose Edit > Add To Selecton & Scale. This will add the stll frame to the entre 
descripton track.

10 Move the playhead to the beginning of the tmeline, choose File > Save As and save the 
combined sound/image fle as a self-contained movie. Select (Edit > Select All) and copy 
(Edit > Copy) the entre track.

11 Switch back to the window containing the original, undescribed movie. Assuming the 
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playhead has not been moved since the image was exported, choose Edit > Paste. (If the 
playhead has moved, repositon it at the exact point in the tmeline where you exported 
the frame.)

12 Play the movie. When the frst extended descripton begins to play, the video will 
appear to pause; when the descripton is done playing, video playback will resume. 
Choose File > Save As and save the clip as a self-contained movie.

13 Move the playhead to the next spot in the tmeline where an extended descripton is 
required. Repeat steps 4-11 to insert the remaining descripton fles.

14 Afer all the descriptons have been added, choose File > Export and export the fle as 
Movie to QuickTime Movie. This will combine all the audio tracks into a single track, 
giving you an open-described movie.

15 Open the newly exported movie in QuickTime, choose File > Export, then choose Movie 
to iPod.

Your movie with extended descriptons is now ready to upload to iTunes U.
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Part 5:  Creatng Accessible iTunes U Documentaton
iTunes allows you to upload not just audio and video materials; it also supports the use 
of PDF documentaton. Screen readers are especially afected by the way in which a PDF 
is created, and a PDF that hasn’t been made accessible can be difcult or impossible for 
a blind or visually impaired user to navigate. This secton will outline the steps necessary 
to ensure that the PDFs you create are as accessible as possible.

A screen reader doesn’t actually read the PDF directly from the screen; instead, it reads 
from the code. In a PDF document, this code is represented by tags, which in turn 
represent the structure and content of the document itself. If you’re familiar with HTML, 
you’ll understand PDF tags very quickly. 

As in HTML, every element of a PDF must be identfed, or tagged—for example, text can 
be tagged as a paragraph, a heading, a list, etc. Image tags allow authors to include text 
alternatves, and background or unimportant images can be tagged so they are hidden 
from screen readers. Data tables can also be marked up in a manner that makes them 
usable by assistve technology. Generally speaking, if a PDF is tagged properly, most 
assistve technology will be able to navigate and read it. 

Ensuring proper reading order is another aspect of creatng an accessible PDF. Reading 
order is represented by tags in the tag tree. The process of convertng the source 
document to PDF will usually result in a satsfactory reading order, but there will be 
cases where you’ll need to re-order the tags somewhat to present informaton so it 
makes the most sense to someone who can’t see the screen. 

A properly tagged PDF is useful for visual users, too, because tags permit the document 
to be refowed for small screens or viewer windows. In a refowed document, text and 
other elements do not have to be scrolled horizontally, even when the window 
dimensions change. Refowed documents can be more easily read on mobile devices, for 
example, or on the desktop when the viewer window has been reduced to a small size. 

Following the techniques described in this secton will greatly improve the accessibility 
of your PDF documentaton, but you must always check your work with a screen reader 
before uploading it to iTunes. Learning to use a screen reader will not only thoroughly 
test the structure of the fle, it will help you navigate the document in a manner similar 
to a reader who actually uses assistve technology: if you can read the document 
accurately, chances are a blind or visually impaired user will be able to do so as well. 
Mac OS X comes with its own screen reader, VoiceOver. Popular Windows screen 
readers include JAWS and Window-Eyes; you can download demonstraton sofware 
before you buy. 

http://www.gwmicro.com/
http://www.freedomscientific.com/
http://www.apple.com/accessibility/voiceover/
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5.1: Tools for creatng accessible source documents

The guidelines below will provide a basic framework for preparing accessible source 
documents and PDFs. Before beginning, learn more about PDF accessibility from Adobe’s 
Accessibility Resource Center, and by downloading resources and tutorials from Adobe’s 
A  ccessibility Training Resources  , including documents pertaining to Acrobat 8 and 9. 
Additonally, the book Web Accessibility: Web Standards and Regulatory   Compliance   has 
a chapter that covers many aspects of making accessible PDFs.

To create an accessible PDF, you’ll need the following sofware:

• Adobe Acrobat 9 Pro  

• Adobe Reader  

• An applicaton that will export tagged PDFs. See the discussion below for more 
informaton. 

• A screen reader to test your work, as described above

No source-to-PDF conversion sofware, built-in or third-party, will always create a 
completely accessible PDF document at the push of a buton, but how well you author 
the source fle will have a big impact on how much work you’ll have to do afer the 
conversion in order for the document to be as accessible as possible. No mater what 
applicaton you use to create the source document, Adobe Acrobat Pro is required to 
complete the process of making your document accessible. You can also use Acrobat to 
add accessibility enhancements to PDFs for which no source documents exist. See Part 
5.3 for details.

Some applicatons, such as OpenOfce, Word for Windows and InDesign, come with 
built-in capabilites to export tagged PDF. HTML can also be converted to PDF. When you 
install Acrobat, it installs an add-in called PDFMaker into Word (and other Ofce 
applicatons), making it easier to create and export accessible PDFs from those source 
documents. (You’ll fnd more informaton about using Word to export tagged PDF in the 
Adobe Acrobat 9 Accessibility Guide.) 

For this demonstraton we’ll use Writer, part of the OpenOfce suite, to create the 
source document. Writer exports tagged PDF from both Mac and Windows, and it has 
other features to help you create documents that will successfully convert to accessible 
PDFs. It can also import documents created in other formats, including Word. 

http://www.openoffice.org/
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/products/acrobat/
http://get.adobe.com/reader/
http://www.adobe.com/products/acrobat/
http://www.friendsofed.com/book.html?isbn=1590596382
http://www.friendsofed.com/book.html?isbn=1590596382
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/accessibility/
http://www.adobe.com/accessibility/
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5.2: Creatng source documents that will convert to accessible PDF

Here are the basic steps for creatng source documents that will translate into accessible 
PDFs.

1 Confgure the source applicaton to export tagged PDF.

Most applicatons are by default set to export untagged PDFs. In Writer, you can default 
to a tagged export by choosing File > Export as PDF, then checking the Tagged PDF box, 
as shown below.

2 Structure the document using styles, not just by formatng text.

Rather than highlightng text and manually altering the formatng, create and apply 
styles to format your document (just as you would in HTML). For example, create styles 
for each heading level (naming then Heading 1, Heading 2, etc., but not H1, H2, etc.) and 
apply them each tme you add a heading to your document. Or, if you’re using data 
tables, create a table-header style and a table-contents style. This will not only visually 
distnguish the header cells from the data cells; Writer will export <TH> and <TD> cells in 
the tagged PDF, which the screen reader can use to help the user navigate and 
understand the table.
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Writer comes with a long list of default styles. To use them, choose Format > Styles and 
Formatng to access the Styles panel, shown below.

Double-click the style you want to use, then start typing. Or, if you’ve already typed text 
in the document, highlight the text you want to style, then double-click a style from the 
list. (The styles you use most ofen will also appear in the Formatng toolbar.) If the 
default styles aren’t formated to your liking, right-click the style you want to apply, 
choose Modify from the context menu, and change the style characteristcs to ft your 
design. To create a new style, right-click anywhere in the Styles and Formatng panel 
and choose New, as shown below. 

In the Styles dialog, defne the characteristcs you want, give the style a name and click 
the OK buton. Your new style will appear in the Styles panel as well as in the Formatng 
toolbar, so you can apply it whenever necessary.

The most commonly used styles in text documents tend to be headings, default (or 
body) text, lists, table header and table data cells. If you set up these styles before you 
start writng your document, you’ll save tme by not having to apply them afer the 
document has been writen.
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3 Add text equivalents (i.e., alt text) to all images.

As in an HTML document, every image must contain a text equivalent, sometmes called 
alternatve text or alt text. Important images should be summarized or described briefy 
(a sentence or two), and unimportant images should be tagged as artfacts or 
background so they will be ignored by assistve technology. (The later is done using 
Acrobat Pro afer you convert the fle; see Part 5.3 for details.) 

In Writer, add an image to the document by choosing Insert > Picture > From File, then 
browse to the image. Once you’ve inserted the image, choose Format > Picture or 
double-click the image to see the Picture dialog. Click the Optons buton and type a 
descripton into the Alternatve Text feld, as shown below.

Apply a text equivalent to every image in your document. See Part 5.3 for informaton on 
tagging unimportant or decoratve images.

Some images, especially those of a scientfc or mathematcal nature, can be difcult to 
describe accurately. NCAM has created a set of guidelines for describing images in 
science textbooks and related materials; you’ll fnd helpful informaton there regardless 
of your subject mater. 

4 Distnguish between header and data cells in data tables.

Data tables can be classifed as simple or complex. Simple data tables generally have one 
row of headers and/or one column of headers. Complex data tables can have nested 
row/column headers, with some headers spanning multple data cells. 

http://ncam.wgbh.org/publications/stemdx/
http://ncam.wgbh.org/publications/stemdx/
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In Writer, set up your table with the appropriate number of cells. You can use Writer’s 
default styles for table headers and contents or modify them to suit your design (see 
step 2, above). If you set up these styles before you create the table, you can just choose 
the Table Heading or Table Contents style and start typing in the appropriate cell. If 
you’ve already created a complete data table but haven’t yet styled it, the steps below 
will show you how to distnguish header cells from data cells.

a.  Choose Format > Styles and Formatng to open the Styles panel.

b.  Highlight the row of headers, then double-click Table Heading in the Styles panel.

c.  Highlight the column of headers and choose Table Heading.
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d.  Highlight the data cells and choose Table Contents. 

When you export the document as PDF, the table headers will appear in the tag tree as 
<TH> and the content (or data) cells will appear as <TD>; screen readers will use these 
tags to help users navigate the table. If your data table contains nested headers, or 
headers that span multple columns or rows, just make sure that you tag all the headers 
and data cells with the appropriate header or data styles, as shown above. 

5 Convert the document to PDF.

Afer you’ve writen and formated your document, choose File > Export as PDF. Click the 
General choose and make sure the Tagged PDF box is checked. Click the Export buton, 
give the fle a name and click Save. 

6 Open the document in Acrobat Pro.

Using Acrobat Pro, open the newly converted PDF. You’ll always want to see the tag tree, 
so open View > Navigaton Panels. Drag the Tags tab over to the dock on the edge of the 
screen so you’ll be able to easily fnd it later, as shown below. 
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Click Tags once and press Shif-8 to expand the entre tag tree...

...and open the Optons menu in the Tags panel and choose Highlight Content, as shown 
here.

Actvatng Highlight Content allows you to visually associate each tag with an element in 
the document. This will come in handy later, especially when you’re verifying the reading 
order. You won’t have to drag the Tags panel to the dock every tme you open a PDF, but 
you will always have to expand the tag tree and choose Highlight Content.
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7 Run an accessibility check.

Acrobat comes with an accessibility checker that will fnd common errors and tell you 
how to fx them. However, it can only check for machine-verifable problems. For 
example, it will tell you that alt text is missing from an image, but it cannot tell you 
anything about the quality of existng alt text. It also can’t tell you if the cells of a data 
table have been correctly tagged with <TH> and <TD>. These and other items must be 
verifed manually by inspectng the tags in the tag tree. 

To run an accessibility check, choose Advanced > Accessibility > Full Check. Choose 
Create Accessibility Report and Include Repair Hints. Specify Adobe PDF in the Checking 
Optons area, select all the checking optons and click the Start Checking buton. If 
Acrobat fnds errors, a report will open in the Accessibility panel. The report will give you 
details on how to correct most problems, so read it carefully and follow the instructons. 
Three common errors are covered below. 

Missing alt text

If an important image is missing alt text, correct this error in the source, not in the PDF, 
and then re-export. If an unimportant or decoratve image is missing alt text, you can tag 
it in the PDF as an artfact or background so it will be ignored by a screen reader. See 
Part 5.3 for details.

Missing language specifcaton

The language specifcaton tells assistve technology what language to use when reading 
the document. Choose File > Document > Propertes, then click the Advanced buton. 
Choose the language from the list in the Reading Optons area to set the language for 
the entre document.

Items missing from tag tree

Some items, frequently background images, may not get tagged during the export 
process, so you must tag the item manually. See Part 5.3 for details.

You can fnd more documentaton about using the Acrobat accessibility checker at 
Adobe’s Accessibility Training Resources. 

8 Verify the reading order.

The reading order of the document is determined by the order of tags in the tree. It is 
quite likely that the PDF export from the source document will result in a reading order 
that is nearly correct, but occasionally some items will need to be relocated. Because a 
screen reader conveys the document data to the user by following the tag tree, it’s 
important to make sure that the tags are all in the right order. 

To verify the reading order using Acrobat, open the Tags panel, expand the tag tree and 
choose Highlight Content from the Optons menu, then use the arrow keys to move 
through the tree, watching the focus in the document pane as it moves through the 
document itself. The order in which the focus moves will correspond to the order in 
which the screen reader reads the document to the user. If you see that the reading 
order is incorrect, you can drag the tag nodes around the tree into the proper order, or 
click the tag(s) you want to move and use the Cut/Paste choices in the Optons menu. 
Relocatng tags is not necessarily a difcult task, but you must work carefully because 
Acrobat has no undo feature for putng the tags back in their original locatons. Save 

http://www.adobe.com/enterprise/accessibility/training.html
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your work frequently and keep a backup copy on hand. 

You can also alter the reading order by using the Order panel. Choose View > Navigaton 
Panels > Order, and drag the Order tab into the dock on the edge of the screen to make 
it easier to fnd the next tme you need it. You’ll see the reading order in both the Order 
panel as well in the document pane itself, as shown below.

To change the reading order of whole blocks of text, simply drag the tags around in the 
Order panel.

9 Check your work with a screen reader.

Even if Acrobat tells you that there are no accessibility errors in your PDF, you must 
always check your work with a screen reader. Mac OS X comes with its own screen 
reader, VoiceOver. Popular Windows screen readers include JAWS and Window-Eyes; 
you can download demonstraton sofware before you buy. You can learn more about 
how screen readers work by reading some fact sheets at the WebAIM site.

Open the document using Adobe Reader (not Acrobat) and read it with a screen reader. 
Beter stll, give the document to an experienced screen-reader user for an evaluaton. 
Among other things, a screen reader will make it immediately obvious if the reading 
order is correct or if the alt tags make sense. If you fnd errors, correct them and check 
the document with a screen reader again. 

5.3: Creatng accessible PDFs when no source document is available

While it’s always best to add accessibility enhancements to the source document before 
convertng it to PDF, there may be tmes when you must work with a PDF for which no 
source document exists. In these cases, you can use Acrobat to repair the document and 
make it as accessible as possible. The basics are covered below, and you’ll fnd more 
informaton in the Adobe documents highlighted in Part 5.1.

1 Check the document for tags.

Open the document in Acrobat and then open the Tags panel (see Part 5.2, #6 for 
details). If you can see that the document has tags, you can skip to #2, below. If the 
panel says “No tags available,” you’ll need Acrobat to add them for you. Choose 
Advanced > Accessibility > Add Tags to Document. Acrobat will tag the document and 
then display a collapsed tag tree in the Tags panel. Expand the tree by pressing Shif+8, 
then choose Highlight Content from the Optons menu.

http://get.adobe.com/reader/
http://www.webaim.org/articles/screenreader_testing/
http://www.webaim.org/articles/screenreader_testing/
http://www.gwmicro.com/
http://www.freedomscientific.com/
http://www.apple.com/accessibility/voiceover/
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While Acrobat does a good job of tagging each element in the document, it doesn’t 
necessarily tag everything correctly. It will make its best guess based on the document’s 
structure and layout, but it has no way of knowing with complete certainty, for example, 
whether a heading should be tagged as a Heading 1 or a Heading 3, or whether cells in a 
table should be tagged as headers or data. And while it can recognize and tag an image, 
it cannot automatcally generate alternatve text or determine whether the image should 
be tagged as an artfact. 

Now that you’ve tagged the document, you’ll need to check the tags to make sure they 
accurately refect the structure of the document. Below are some of the common 
problems encountered when tagging untagged documents. You can learn about other 
solutons by reading the tutorials at Adobe’s Accessibility Training Resources site.

2 Verify the reading order.

See Part 5.2, # 8, for informaton on checking and adjustng the reading order. 

3 Add text equivalents to images.

Acrobat will recognize and tag most images but it cannot add alternatve text to them. 
You must do that yourself by following these steps.

• With the tag tree expanded, right-click an image tag (it will say “Figure”) and choose 
Propertes from the context menu (or click the tag once and choose Propertes from 
the Optons menu). Click the Tag buton and enter text in the Alternate Text box, as 
shown below. 

http://www.adobe.com/enterprise/accessibility/training.html
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• If the image is unimportant or decoratve, open the Propertes window as described 
above and, in the Type feld, enter “Artfact” (no quotes, capital A). You’ll see the tag 
change from Figure to Artfact in the tree. Any item tagged as an Artfact will be 
ignored by a screen reader. If you need to tag the item as a background image, see 
step 4, below.

4 Tag images as background.

If you have an image that serves as a background to text or another image, you can tag it 
so it will be ignored by screen readers. Choose Advanced > Accessibility > TouchUp 
Reading Order and move the panel to the side. Drag a rectangle around the item you 
want to tag as a background (or double-click it) and click the Background buton, as 
shown in the image below.
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5 Verify or add headings.

Acrobat will tag text that it thinks is a heading with an H tag (corresponding to Heading 
1, Heading 2, etc.). It might tag the heading levels correctly, but there’s a reasonable 
chance that it won’t because it can’t detect the context in which the heading appears. 
However, it’s a simple mater to change a heading level, or to re-tag an incorrectly 
tagged heading.

• With the tag tree open, right-click a heading tag and choose Propertes from the 
context menu (or click the tag once and choose Propertes from the Optons menu). 
Click the Tag buton, and change the heading level in the Type list, as shown below.

• You can also re-tag headers using the TouchUp tool. Choose Advanced > Accessibility > 
TouchUp Reading Order, drag a rectangle around the text or block of text that should 
be a header and click the appropriate heading buton in the TouchUp tool. Only 
Heading 1-Heading 3 are available in the tool; if you need levels 4-6, tag the header 
with the TouchUp tool, then click the tag in the tree, open the Propertes window and 
change the level there. 

6 Verify data-table structure.

Acrobat will usually recognize a data table in a source document, but it probably won’t 
correctly tag the header and data cells. Manually retagging data tables will greatly 
improve the accessibility of your document.

• Choose Advanced > Accessibility > TouchUp Reading Order. If you see that Acrobat has 
correctly tagged the data table as a single table, proceed to the next step. If Acrobat 
has mistakenly tagged the table as a series of separate data tables, drag a box around 
the entre table and click the Table buton in the TouchUp window. This will create a 
single data table.
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• Right-click the table and choose Table Editor, then right-click again on the table and 
choose Table Editor Optons. For easy visual diferentaton, change the color schemes 
for data and header cells. Also check the two Show Cell boxes, as shown in the image 
below. 

• Click OK. The color choices you specifed will now be applied to the table, and the cells 
themselves will be labeled as TD or TH, as shown in the image below.

• To change a data cell to a header cell, right-click the cell and choose Table Cell 
Propertes. In the dialog, change the designaton to Header Cell, as shown below, and 
specify the scope (directon) of the cell.



Creatng Accessible iTunes U Content 63

Afer you’re fnished, the table will look something like the one shown below.

Repeat as necessary for the other table cells.

• You can also re-tag table cells directly in the tag tree. Right-click a <TH> or <TD> tag in 
the tag tree and choose Propertes from the context menu (or click the tag once and 
choose Propertes from the Optons menu). Click the Tag tab, and choose Table Data 
Cell or Table Header Cell from the Type list, as shown below.

7 Run an accessibility check and verify results with a screen reader.

As discussed in Part 5.2, check your work not only with Acrobat’s accessibility checker 
but also with a screen reader. Choose Advanced > Accessibility > Full Check, specify the 
PDF optons, generate a report and read it carefully, correctng errors as described in 
Part 5.2. When you’ve reduced or eliminated the errors, always test the document with 
Adobe Reader and a screen reader, verifying the accessibility of your document before 
uploading it to iTunes U.
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Appendix 1:  Adding Wired Sprites to Control Captons and 
Descriptons
QuickTime Player, iTunes, iPhone and iPod nano all provide menus or butons to control 
SCC closed captons when they are available in a presentaton (see Appendix 2 for details 
on how to access these controls). If you’re using QTText to integrate closed captons, you 
must add your own controls to the presentaton if you want to give users the ability to 
turn the text on and of. The same is true for audio descripton tracks. These controls can 
take the form of wired sprites, which are QuickTime tracks that permit interactvity. 
There is a trade-of, however: wired sprites can be operated only when the movie is 
played using QuickTime or iTunes. A movie with wired sprites cannot be copied to or 
used on iPhone or iPod. See Part 1.5 for more informaton.

Below is a picture of capton and descripton controls integrated into a movie. You can 
also watch a sample video containing wired sprites that control the display of captons 
and descriptons. 

To add control elements to a QuickTime movie, you will need the following items:

• QuickTime Pro  

• A QuickTime movie with embedded captons and/or audio descriptons

• Control elements; that is, the wired sprites themselves. You can download basic 
controls for captons and descriptons from NCAM, or make your own using sofware 
such as LiveStage from Totally Hip. If you’re unfamiliar with building wired sprites, frst 
learn about interactvity in QuickTime movies from the Apple Developer Connecton. 

http://developer.apple.com/documentation/quicktime/IQ_InteractiveMovies/preface/QT_Interactive_preface.html
http://www.totallyhip.com/
http://ncamftp.wgbh.org/richmedia
http://ncamftp.wgbh.org/richmedia
http://www.apple.com/quicktime
http://deimos3.apple.com/WebObjects/Core.woa/Browse/wgbh.org.2010579900.02010579902.2084821080?i=1842088322
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For the purposes of demonstraton, the instructons below use NCAM’s pre-made 
capton-control elements, so frst you should download cc_of_at_start.mov or 
cc_on_at_start.mov.

1 Open the captoned QuickTime movie.

2 Choose Window > Show Movie Propertes. In the track list, make sure the capton track 
has been named “captons,” without quotes. If it has a diferent name, double-click it 
and change the name now.

3 In a new QuickTime window, open cc_of_at_start.mov.

4 Select (Edit > Select All) and copy (Edit > Copy) the entre track.

5 Switch to the window containing the captoned movie.

6 Make sure the playhead is positoned at the beginning of the clip. Choose Edit > Add to 
Selecton & Scale. The capton butons will be added to the presentaton, as shown 
below. In the Movie Propertes window you will see two new tracks in the track list: 
ccofatstart and background.

7 Click the of and on butons to toggle the capton display. If this doesn’t work, check the 
Movie Propertes window to make sure you’ve named the capton track as “captons.”

8 If you want to repositon the buton, open the Movie Propertes window. Click 
ccofatstart in the track list, then click the Visual Setngs buton and enter the new 
coordinates in the Ofset area. The frst entry is the X (horizontal) positon; the second 
entry is the Y (vertcal) positon. Repeat the same ofset for the background track. You 
may also fnd that ofsetng the video region (click Program Video in the track list) is 
useful.

http://ncamftp.wgbh.org/richmedia/
http://ncamftp.wgbh.org/richmedia/
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9 When the controls are positoned where you want them, make sure the text track is 
turned of by clicking the “of” buton, then choose File > Save As and save the clip as a 
self-contained movie.

If you want the captons to be on when the movie begins playing, just substtute the fle 
“cc_on_at_start” in step 3. Afer repositoning the elements and testng the toggles, be 
sure to save the movie with the captons on rather than of.

If you want to add toggles for audio descriptons instead of captons, download 
ad_of_at_start.mov or ad_on_at_start.mov instead. Then follow the instructons above, 
observing two substtutons: in step 2, name the audio-descripton track that you have 
embedded as “audiodesc”; in step 3, use the fle ad_of_at_start.mov or 
ad_on_at_start.mov.

http://ncamftp.wgbh.org/richmedia/
http://ncamftp.wgbh.org/richmedia/
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Appendix 2:  Turning SCC Closed Captons On and Of
Below are instructons for turning SCC captons on and of using the controls that are 
included with many Apple multmedia players.

QuickTime Player

1 Choose View > Show Closed Captoning to reveal the captons, or View > Hide Closed 
Captoning to hide them.

2 To specify default behavior: choose QuickTime > Preferences > General, and check or 
uncheck the box next to Show Closed Captoning When Available.

iTunes

1 Method 1: open Controls > Audio & Subttles; choose Show or Hide Closed Captoning.

2 Method 2: roll the pointer over the video window, click the balloon in the control bar 
and choose Show or Hide Closed Captoning.

3 To specify default behavior: choose iTunes > Preferences > Playback, and check or 
uncheck the box next to Show Closed Captoning When Available.

iPhone

Open Setngs > iPod; in the Video area move the Closed Captoning slider to on or of.

iPod nano

Open Videos > Setngs, scroll to Captons and select on or of.

iPod classic

Open Videos > Setngs, scroll to Captons and select on or of.

Apple TV

Open Setngs > Audio & Video, Closed Captoning, and select Of, Enhanced or Standard.
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Appendix 3:  Capton Support in Apple Products

Device Capton 
formats

Decode SCC 
captons?

Support wired 
sprites?

Support closed 
descriptons?

QuickTime Player for 
Mac and Windows

SCC, QTText Yes Yes Yes; requires wired 
sprite

iTunes Player for Mac 
and Windows

SCC, QTText Yes Yes Yes; uses menus or 
on-screen controller

iPhone, iPod touch SCC, QTText Yes No Yes; uses on-screen 
controller

iPod nano SCC, QTText Yes No No; only plays open 
descriptons

iPod shufe None No No No; only plays open 
descriptons

iPod classic SCC, QTText Yes No No; only plays open 
descriptons

Apple TV SCC, QTText Yes No No; only plays open 
descriptons

http://www.apple.com/appletv/
http://www.apple.com/ipodclassic/
http://www.apple.com/ipodshuffle/
http://www.apple.com/ipodnano/
http://www.apple.com/iphone/
http://www.apple.com/itunes/
http://www.apple.com/itunes/
http://www.apple.com/quicktime
http://www.apple.com/quicktime
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Appendix 4:  Closed Captoning and Audio Descripton 
Resources 

Major captoning service providers include:

Media Access Group at WGBH 

WGBH Educatonal Foundaton 
1 Guest Street
Boston, MA 02135 
Voice/TTY: (617) 300-3600 
Fax: (617) 300-1020
e-mail: access@wgbh.org

Natonal Captoning Insttute

1900 Gallows Rd., Suite 3000 
Vienna, VA 22182 
Voice/TTY: (703) 917-7600 
Fax: (713) 917-9878 

VITAC 

101 Hillpointe Dr. 
Canonsburg, PA 15317-9503 
Phone: (800) 278-4822 
Fax: (724) 514-4111

A directory of captoning service providers is also available from the Closed Captoning 
Web.

Audio descripton service providers include:

Media Access Group at WGBH 

WGBH Educatonal Foundaton 
1 Guest Street
Boston, MA 02135 
Voice/TTY: (617) 300-3600 
Fax: (617) 300-1020
e-mail: access@wgbh.org

CaptonMax

2438 27th Avenue South 
Minneapolis, MN 55406 
Phone: (612) 341-3566 
Fax: (612) 341-2345 

Narratve Television Network 

5840 South Memorial Dr., Suite 312 
Tulsa, OK 74145-9082 
Phone: (918) 627-1000 
Fax: (918) 627-4101 

http://www.narrativetv.com/
http://www.captionmax.com/
mailto:access@wgbh.org
http://access.wgbh.org/
http://www.captions.org/
http://www.captions.org/
http://www.captions.org/services.cfm
http://www.vitac.com/
http://www.ncicap.org/
mailto:access@wgbh.org
http://access.wgbh.org/
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Appendix 5:  General Resources 

Regulatons and guidelines

• Secton 508 Guidelines  

Secton 508 requires electronic and informaton technology developed, procured, 
maintained or used by Federal agencies to be accessible to people with disabilites. This 
includes Web sites and multmedia.

• Web Content Accessibility Guidelines 2.0  

Complete recommendatons from the Web Accessibility Initatve at the World Wide 
Web Consortum (WAI/W3C) for making Web and multmedia content more accessible 
to people with disabilites.

• IMS Guidelines for Developing Accessible Learning Applicatons  

Guidelines developed by the IMS Accessibility Project Group to provide a framework for 
the distributed-learning community. 

• Accessible Digital Media  

Accessibility guidelines from the Carl and Ruth Shapiro Family Natonal Center for 
Accessible Media (NCAM) focusing on solutons for accessible multmedia.

• Efectve Practces for Descripton of Science Content within Digital Talking Books  

Image-descripton guidelines from NCAM focusing on science, technology, engineering 
and math content.

Accessible PDF

• Adobe’s Accessibility Resource Center  

General informaton and documentaton about accessibility eforts at Adobe.

• Adobe’s Accessibility Training Resources  

Documentaton and tutorials relatng to the accessibility features of Acrobat 8 and 9. 

• Web Accessibility: Web Standards and Regulatory Compliance   

Book about Web accessibility, including a chapter covering PDF accessibility.

• PDF Accessibility at WebAIM  

Techniques for creatng accessible PDF materials.

Accessibility at Apple

• Apple’s Accessibility Homepage  

Informaton about Apple’s accessibility eforts as they relate to hardware and sofware.

• VoiceOver  

Details about the built-in screen reader for Mac OS X and iPhone 3GS.

• Mac OS X  

Informaton about the accessibility features built into Mac OS X.

http://www.apple.com/accessibility/macosx/vision.html
http://www.apple.com/accessibility/voiceover/
http://www.apple.com/accessibility/
http://www.webaim.org/techniques/acrobat/
http://www.friendsofed.com/book.html?isbn=1590596382
http://www.adobe.com/enterprise/accessibility/training.html
http://www.adobe.com/accessibility/
http://ncam.wgbh.org/publications/stemdx/intro.html
http://ncam.wgbh.org/publications/adm/
http://ncam.wgbh.org/salt/guidelines/
http://www.w3.org/TR/2008/REC-WCAG20-20081211/
http://section508.gov/index.cfm?FuseAction=Content&ID=12#Web
http://section508.gov/index.cfm?FuseAction=Content&ID=12
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Other screen readers

• Windows-Eyes  

The recommended screen reader for iTunes U on Windows

• JAWS  

Popular screen readers for Windows. Demonstraton copies are available.

• Orca (linux)  
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